Muncul Error: /lib/ld-linux.so.2: bad ELF interpreter

Kejadian ini terjadi ketika saya ingin running suatu proses daemon yang ada di server saya. Sebenarnya, dari kemarin mau mencoba bernostalgia dengan daemon IRCd yang jadoel begitu. Namun ketika memasang bircd, ternyata muncul error demikian ketika ingin runngin ./bircd. Lalu bagaimana cara fixnya?

error execute bircd

Biasanya masalah ini terjadi pada Centos x64 seperti yang saya gunakan saat ini. Kalau saya baca berdasarkan tutorial yang ada pada internet, terdapat package 32bit yang harus kita pasang juga. Karena x64 umumnya hanya memasang library yang 64bit saja sendiri.

Untuk Centos

yum install glibc.i686

Centos yang lebih jadoel lagi

yum install glibc.i386

Untuk Ubuntu

apt-get install ia32-libs

Nah ketika susah ekseksusi berdasarkan distro yang kita gunakan, singkat kata daemon bircd itu bisa kembali berjalan. Mantap.

Leave a Reply

Your email address will not be published. Required fields are marked *