VestaCP: Site error: the ionCube PHP Loader needs to be installed. This is a widely used PHP extension for running ionCube protected PHP code, website security and malware blocking. Please visit get-loader.ioncube.com for install assistance.

VestaCP muncul error saat mengakses Softaculous dari panel Vesta. Jika diteliti, munculnya error ini disebabkan karena salah satu komponen php loader Vesta tidak disertai dengan module php ioncube.

Lalu bagaimana cara betulin?

Merujuk pada resolusi yang ada pada forum Vesta, kita harus cek terlebih dahulu versi php versta yang sedang digunakan. Caranya sebagai berikut :

$VESTA/php/bin/php -v

Kemudian kita pastikan apakah module softaculous pada konfigurasi vesta sudah di load.

grep 'SOFT' $VESTA/conf/vesta.conf

Jika pada command pertama di atas tidak ada module php ioncube loader dan module Softaculous sudah di load pada konfigurasi Vesta, berarti kita harus eksekusi script buatan tim developer untuk load php ioncube tersebut.

/usr/local/vesta/ioncube/ioncube.sh

Kemudian silakan akses website anda kembali dimana membutuhkan php ioncube loader tersebut. Contohnya seperti Softaculous.

Leave a Reply

Your email address will not be published. Required fields are marked *

This site uses Akismet to reduce spam. Learn how your comment data is processed.